Los polígonos regulares

Autor: Enrique Ocaña González (eocanha arroba igalia punto com)
Modificado por: Daniel Ajoy (dajoy arroba openworldlearning punto org)

En esta sección vas a aprender a decirle a la tortuga cómo debe dibujar algunas figuras básicas, pero primero debes descubrir por ti mismo la técnica respondiendo a algunas preguntas.

En primer lugar vamos a decirle a la tortuga que dibuje un triángulo de 50 pasos de lado:

av 50

Muévete 50 pasos hacia adelante

gd 120

Gira 120 grados hacia la derecha

av 50

Muévete 50 pasos hacia adelante

gd 120

Gira 120 grados hacia la derecha

av 50

Muévete 50 pasos hacia adelante

gd 120

Gira 120 grados hacia la derecha


Imagen: poligonos 1

Ahora vas a entender por qué hay que girar 120 grados cada vez para dibujar el triángulo:

  1. ¿En cuántos grados se divide una vuelta completa? (Ver solución)
  2. ¿Cuántos lados tiene un triángulo? (Ver solución)
  3. ¿Cuántas veces tiene que girar la tortuga para dibujar un triángulo? (Ver solución)
  4. Al finalizar el dibujo, ¿ha dado la tortuga una vuelta completa? (Ver solución)
  5. Entonces, si tiene que dividir 360 grados (que tiene una vuelta en total) entre 3 giros, ¿a cuántos grados tocan por cada uno de los giros? (Ver solución)
  6. ¿Y cuántos giros tendría que hacer si quisiera dibujar un pentágono? (Ver solución)
  7. ¿Y cuántos grados tocarán por cada giro en ese caso? (Ver solución)
  8. ¿Qué habrá que decirle entonces a la tortuga para que dibuje un pentágono? (Ver solución)
  9. ¿Y para un hexágono? (Ver solución)
  10. ¿Y para un polígono regular cualquiera de N lados? (Ver solución)

Así quedaría un decágono (polígono de 10 lados) con 30 pasos de lado (Ver solución 11):

Imagen: poligonos 2

¡Vaya! Parece que ya conoces la palabra repite ... Entonces seguro que sabes dibujar esta rosa que se hace con 6 pentágonos (Ver solución 12):

Imagen: poligonos 3

¿Quieres saber un secreto que me ha contado la tortuga? Puedes grabar tus dibujos favoritos a disco con la opción Bitmap --> Guardar Como... en el menú de la ventana gráfica, y puedes imprimirlos con la impresora usando la opción Bitmap --> Imprimir... Pregúntale a tu profesor para que te ayude.

1. Soluciones

  1. En 360 grados.
  2. 3 lados.
  3. 3 veces.
  4. Sí, ha dado una vuelta completa.
  5. 360 grados / 3 giros = 120 grados por cada giro
  6. 5 giros.
  7. 360 grados / 5 giros = 72 grados por cada giro

2. Solución 8

av 50
gd 72
av 50
gd 72
av 50
gd 72
av 50
gd 72
av 50
gd 72

3. Solución 9

360 grados / 6 giros = 60 grados por giro

av 50
gd 60

...(repetido 6 veces en total)...

Es decir, si usamos al orden repeat sería:

repite 6 [ av 50 gd 60 ]

4. Solución 10

repite N [ av 50 gd 360/N ]

5. Solución 11

repite 10 [ av 30 gd 360/10 ]

6. Solución 12

repite 6 [ repite 5 [ av 50 gd 360/5] gd 360/6 ]

7. Preguntas, Dudas, Comentarios, Peticiones

Nombre:
Ciudad y País:
Email:
 

8. Enlaces

Página Principal

Regresar al Logo Quest


Generado con PureJoy.
Fecha: 15:30 - Jul 06, 2017